2) Назначить внутренние IP адреса, настроить DHCP-клиент, DNS-сервер, DHCP-сервер, включаем NAT маскарад, UPnP, NTP, Интернет TV.

По странной особенности роутеров микротик, они идут без пакетов NTP, и IGMP Proxy (IP TV), для этого скачаем все пакеты под наше устройство, с нашей версией прошивки, и устройством выполним в терминале:
system resource print
в ответ роутер нам выдаст инфрмацию о себе. Интересуют нас позиции, такие как у меня architecture-name: mipsbe и version: 5.26 теперь в соответствии с версией и архитектурой скачиваем все пакеты архивом с сайта http://www.mikrotik.com/download
В WinBox открываем Files, и перебрасываем туда пакеты multicast-***.npk и ntp-***.npk после чего перезапустим роутер. Все пакеты установлены.

Для начала определимся с списком внутренних сетей, делать все в одной сети можно, но не хочется, так как хочется получить на выходе большую управляемость. Итак наша сеть 192.168.88.0/24, я разделил её таким вот образом:

Сеть 192.168.88.0/25 это  192.168.88.1 — 192.168.88.127 — основная сеть проводная.
Сеть 192.168.88.128/26 это 192.168.88.129 — 192.168.88.191 — будет основным вайфаем.
Сеть 192.168.88.192/26 это 192.168.88.193 — 192.168.88.254 — дополнительная сеть WiFi, детский или гостевым (DNS ограничивает доступ взрослому контенту + ограничение по скорости)

Ну приступим к настройке, сначала включим DHCP клиент, на интерфейсе провайдера:

/ip dhcp-client
add add-default-route=yes default-route-distance=0 interface=ISP use-peer-dns=yes use-peer-ntp=yes

Теперь назначим адреса на имеющиеся внутренние интерфейсы:

/ip address
add address=192.168.88.1/25 interface=ether2
add address=192.168.88.129/26 interface=wlan1

На этом пока все, третью сеть будем подключать позже.

Теперь включим DNS. Я использую OpenDNS, как независимый и довольно быстрый DNS сервер, в дополнение к серверам выделяемым провайдером. Или вместо них, но тогда нужно поставить use-peer-dns=no при настройке DHCP клиента.

/ip dns
set allow-remote-requests=yes servers=208.67.222.222,208.67.220.220

После этого нам надо раздовать ip адреса на сеть, и вайфай, я буду использовать 2 разных DHCP сервера.

Для начала заведем пул адресов:

/ip pool

add name=dhcp_pool_lan ranges=192.168.88.2-192.168.88.127

add name=dhcp_pool2 ranges=192.168.88.130-192.168.88.191

Сервера DHCP:

/ip dhcp-server

add address-pool=dhcp_pool_lan interface=ether2 name=dhcp1

add address-pool=ddhcp_pool_wifi interface=wlan1 name=dhcp2

И параметры сети:

/ip dhcp-server network

add address=192.168.88.0/25 gateway=192.168.88.1 dns-server=192.168.88.1 ntp-server=192.168.88.1

add address=192.168.88.128/26 gateway=192.168.88.129 dns-server=192.168.88.129 ntp-server=192.168.88.1

Включаем маскарад NAT, после чего у нас должен появиться интернет на подключаемом оборудовании.

/ip firewall nat
add action=masquerade chain=srcnat comment="Masquerade" src-address=192.168.88.0/24 out-interface=ISP

И конечно включаем upnp, чтобы потом не морочиться пробросом портов для игрушек, торентов и так далее:

/ip upnp
set allow-disable-external-interface=no enabled=yes

/ip upnp interfaces//.
add interface=ISP type=external
add interface=ether2 type=internal
add interface=wlan1 type=internal

Вот теперь интернет есть, пока незащищенный без фаервола.
Настроим время:
/system clock set time-zone-name=Europe/Moscow
Если Вы не в москве, укажите Ваш город.
И соответственно NTP клиент и сервер.
/system ntp client
set enabled=yes primary-ntp=194.190.168.1 secondary-ntp=192.43.244.18
/system ntp server
set enabled=yes multicast=yes

И наш IP TV:
/routing igmp-proxy
set quick-leave=yes
/routing igmp-proxy interface
add interface=ether2
add alternative-subnets=0.0.0.0/0 interface=ISP upstream=yes

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *

Этот сайт использует Akismet для борьбы со спамом. Узнайте как обрабатываются ваши данные комментариев.