Ermak`s blog

Мысли вслух

По странной особенности роутеров микротик, они идут без пакетов NTP, и IGMP Proxy (IP TV), для этого скачаем все пакеты под наше устройство, с нашей версией прошивки, и устройством выполним в терминале:
system resource print
в ответ роутер нам выдаст инфрмацию о себе. Интересуют нас позиции, такие как у меня architecture-name: mipsbe и version: 5.26 теперь в соответствии с версией и архитектурой скачиваем все пакеты архивом с сайта http://www.mikrotik.com/download
В WinBox открываем Files, и перебрасываем туда пакеты multicast-***.npk и ntp-***.npk после чего перезапустим роутер. Все пакеты установлены.

Для начала определимся с списком внутренних сетей, делать все в одной сети можно, но не хочется, так как хочется получить на выходе большую управляемость. Итак наша сеть 192.168.88.0/24, я разделил её таким вот образом: продолжение…

Я буду приводить в примере роутер RB951G (такиеже настройки подойдут к всей домашней серии с вайфаем rb751, rb751g, rb951-2n, rb951Ui и т.д. к rb2011 тоже подойдут, но нужно учитывать что в нем 2 чипа коммутации) , и весь пример будет настраиваться на RouterOS 5.26 как самой стабильной на момент написания статьи.

Итак у нас есть 5 портов ethernet,  при объединение портов важно помнить, что объединять порты можно посредством возможностей чипа коммутации вашего RouterBoard, или просто обеднять их в bridge в этом случае трафик пойдет через процессор маршрутизатора. Процессор ресурс ценный, поэтому будем использовать чип коммутации, для этого войдем в терминал, и сбросим конфигурацию, которая есть в нашем микротике по умолчанию:

system reset-configuration no-defaults=yes

Подтверждаем свое решение и подождем пока роутер сброситься, перезапуститься и подключаемся к нему WinBox`ом по макадресу.

После чего, приступим наконец к портам:

/interface ethernet
set 0 name=ISP # Первый порт, который будет смотреть на провайдера назовем ISP (Internet Service Provider)
set 1 name=ether2 # Порт 2 который будет смотреть в нашу локальную сеть.
set 2 master-port=ether2 name=ether3 # Порт 3 его мы объединяем, назначив порт 2 мастер портом.
set 3 master-port=ether2 name=ether4 # Так же назначим порт 2 мастер портом для порта 4
set 4 master-port=ether2 name=ether5 # Так же назначим порт 2 мастер портом для порта 5

Если нужно внести MAC адрес, на котором зарегистрирован интернет у провайдера, можно указать его командой:

/interface ethernet set ISP mac-address=00:11:22:33:44:55
Где 00:11:22:33:44:55 заменить на свой MAC адресс.

Теперь займемся WiFi точкой доступа, зададим настройки безопасности создав профиль profile_wpa2, в примере  использую WPA2PSK, и пороль 12345678:

/interface wireless security-profiles
add authentication-types=wpa2-psk eap-methods=passthrough mode=dynamic-keys name=profile_wpa2  wpa2-pre-shared-key=12345678

Теперь настроим сам интерфейс название сети MikroTik,  посадим мы его на 6 канал, то есть 2437MHz :

/interface wireless
set 0 adaptive-noise-immunity=ap-and-client-mode arp=proxy-arp band=2ghz-b/g/n disabled=no frequency=2437 frequency-mode=superchannel ht-guard-interval=long ht-rxchains=0,1 ht-txchains=0,1 hw-protection-mode=rts-cts hw-protection-threshold=15 l2mtu=2290 mode=ap-bridge periodic-calibration=enabled security-profile=profile_wpa2 ssid=MikroTik tx-power=18 tx-power-mode=all-rates-fixed wireless-protocol=802.11 wmm-support=enabled

В итоге, мы имеем первый порт, уходящий к провайдеру, теперь он называется ISP, 2-5 порты обеднены для работе в локальной сети в «свич», и включен WiFi c шифрованием WPA2PSK, именем сети MikroTik и паролем 12345678

Mikrotik     Не все роутеры одинаково полезны, и я как и большинство долго пользовался асусами, длинками, зюкселями и остальными тренднетами. Многие роутеры можно прошить сторонними прошивками, и получить гораздо больший функционал, чем задумано. OpenWRT и DD-WRT и другие, научат роутер варить кофе и приносить тапочки, качать торенты, работать медиасервером и так далее. Зачастую эти прошивки работают значительно лучше и стабильнее чем те которые установлены на роутер изначально. Но рассказать мне хотелось о маршрутизаторах, которые задумывались как маршрутизаторы, и работают именно как маршрутизаторы, при этом делают это действительно хорошо, и стоят дешевле того ширпотреба которое я упомянул выше. Речь пойдет о продукте латвийский фирмы MikroTik, и их операционной системе RouterOS.   750GL

Столкнулся я с  этим продуктом можно сказать случайно, в какой то момент у меня дома было 2 интернет канала, один странно не стабильный, а другой новый и не проверенный, так как на тот момент работа шла из дома, интернет нужен был всегда, пришлось платить обоим провайдерам, это давало уверенность, что в случае чего интернет будет. Естественно оставить простаивать резервный канал я не мог, да и сделать переход с провайдера на провайдер автоматически (а не перетыкаиванием хобота), я стал искать роутер который бы это умел. Каково же было моё удивление, оказалось что привычные мне D-link, TP-link, trendnet, Asus и т.д. с 2wan портами стоят от 7000руб. при этом в сети было много ссылок на MikroTik RouterBOARD 750 стоимостью ~1200руб, который вроде как это все тоже умел. Ну такие деньги, выделить себе под эксперименты я смог без содрогания, и приобрел  RouterBOARD 750GL….
продолжение…

header_logo

Собственно на сегодня выбирая домой сервер/хранилище выбор из готовых решений (таких как Synology, Qnap) и самосбора, впрочем есть и готовые решения «самосбора» типо HP MicroServer. Так вот, у всех готовых решений есть программное обеспечение (операционка), которая часто хороша но ограничена, а у самостоятельных решений ограниченный выбор этих операционок. Из бесплатного:

1) FreeNAS

2) NAS4Free

3) ZFSGuru

4) OpenMediaVault

Надо ли говорить что создатели всех 4 одни и теже люди, поработавшие в основном в проекте FreeNAS и вышдшие из него по разным причинам.

Первые 3 основаны на FreeBSD, для того чтобы воспользоваться ZFS (по условиям лицензии). Да, ZFS это очень здорово, круто, волшебно и замечательно, но имеет и ряд минусов, и как итог, для домашнего хранилища избыточно, и требует сильно много ресурсов, относительно mdadm raid5 например.

А вот последний, 4 дистрибутив привлекший мое внимание основан на теплом ламповом Debian, что делает его чуть более гибким, и относительно более простым.

Я не буду расписывать OpenMediaVault тем более о возможностях можно прочитать на странице проекта. Я коротко напишу что понравилось мне:

1) Я заменял другой дистрибутив, и рейд 5 у меня уже был собран. Так вот, установка и базавая настройка OMV у меня заняла около получаса. На все (!!!).

2) Базово доступно: SSH,FTP,TFTP, NFS (v3/v4), SMB/CIFS, RSync, LVM,LDAP Directory Service, AFP, Bittorrent client, DAAP server, UPS, iSCSI Target, Antivirus.

3) Есть система плагинов, которые разработчики пополняют. Собственно можно ставить все что угодно, как в обычном дебиане, но плагин это всегда красиво, и через вебморду 🙂

4) Все нужные мне плагины нашлись сразу: transmission-daemon, mini-dlna, plex-media-server, nut.

5) Удобно реализовано управление виртуалкой virtualbox (в ней у меня астериск крутиться).

Да. проект молодой, и пока версия 0.5, тоесть до полного релиза еще далеко, но 3ий месяц он крутиться на моем HP MicroServer в боевом режиме, и показал себя с самой лучшей стороны.

2komПобудило написать положительный отзыв как ни странно сегодняшняя проблема связи, отключился интернет.

Звоню им с сотового, и автоматическая девушка (автоответчик) узнала меня по номеру телефона, тут же сказала номер моего договора, сказала что есть проблема и во сколько проблема будет точно решена, (обещала в 18.00 но решилось все в 16.10, так что обманула) и сообщила номер заявки. Решил продублировать, написал в службу поддержки, созвонился живой молодой человек в течении получаса, продублировал сообщение автоматической девушки и был готов ответить на любые вопросы.

Вот вроде и косяк с их стороны, но пожаловаться не на что, интернета не было 2 часа. Все разъяснили быстро, починили. Готовы для диалога. Да, есть мелкие косяки, но служба поддержки поддерживает 🙂

Да самое главное забыл, про качество связи:

1) за почти пол года, интернет отключался 2-3 раза на час или два.
 2) Скорость: то что по тарифу (у меня было 20-30-35-40-45Mbit/s) и соточка в локалке. Все что обещано все есть, и немного больше, обычно. жаловаться вообще не на что. (роутер у меня гигабитный mikrotik, и в 2ком я в гигабитном клубе).

Субъективно, лучший провайдер из всего того чем я пользовался в Москве (в том числе и по работе), а это провайдеров 20 наверно, многие правда на сегодня уже не существуют.  В общем рекомендую.

Это тест, ме я вид о?

Оформило мне предприятие карту, да не простую карту, дебетовую да зарплатную, дабы деньги заработанные мной на неё переводить. За несколько лет пользования проблем никаких не испытывал, хоть не лучший банк, да и интернет-банк убогонький. Но карту дебетовую и в заграницах принимали, и в России все нормально было. Банкоматы часто встречаются, все метро ими заставлено.
Пришло время и о крупных покупках подумать, и кредит взять, на от года до полутора. У росбанка условия хорошие, кто зарплатными картами пользуеться, тому процент по кредиту сниженый. Убедили, подали заявление, с третьего раза даже кредит получили, первые два девушки за стойками, что-то путали, то срок погашения больше возьмут, то проценты со страховкой не те. И дали нам карточку новую, где вместо «кардхолдера» была надпись буквами иностранными: «prosto dengi» на ней написано, и сказал банк, До 23, каждого месяца, деньги должны быть на ней, выплата месячная, с зарплатной карты брать не умеем мы, так что сюда кладите сумму нужную. Хорошо, согласились мы, и полгода все нормально было, проходили к банкомату, и снимали с зарплатной денюшку, да на новую карту перекладывали, чтоб им пусто с их интернет банком было, что деньги со счета на счет перекладывать не умеет.
Долго сказка сказывается, но полгода с той пары минуло, но двадцать второго числа сего месяца, послала меня жена деньги с карты на карту перекладывать, пришел я в банкомат ихний, что в ДО «Сходненский», поздно пришел в 22.40, снял денги с зарплатной карты пересчитал, возле банкомута ихнего, взял вторую карту что с надписью, сунул код свой ввел, сказал банкомату что «внесение наличных» надобно, открыл пасть банкомат, сунул я ему денюшку, сумму крупную, для меня достаточно. Пошуршал банкомат нутром своим, и красную табличку мне выдал «Операция не может быть произведена по тех. причинам» И карту мой мне высунул. А вот деньги не отдаёт, гад и сволочь он. Я в поддержку звонить кинулся, как же так и что делать мне, говорят мне человеческим голосом, не волнуйся, завтра приходи, пиши заявленице, что банкомат денюшку скушал.
Пришли утром писать заявление, написали как было дело, и приняла заявление женщина Лунякина Л.В. некая, приняла хорошо мило, обещала разобраться в ситуации дала копию заявления, и сказала, что разберутся они после инкассации. И ушли мы одобренные. На понимание банка понадеялись.
Дальше хуже стало, двадцать четвертого, банк сумму задолженности, с зарплатной карты списал не помиловал, мне на жизнь рублей 300 оставили. И на мои возмущения праведные, послали подальше. Козлы, мля.
В итоге, банкомат ихний хитрый, поламатый похоже, скушал сумму крупную, банк с зарплатной карты ещё такую же сумму снял, разбираться никто не хочет, чем детей кормить не понятно мне, ну а банку на это побоку, срать им п…орам, на мужика горемычного.

PS В итоге, имеем, что банк украл у меня сумму ~30000 руб. так как списал её в счет погашения задолженности по кредиту, и на письменные заявления, срать хотели, банкомат скушавший сумму, это банкомат росбанка в офисе росбанка, где весят камеры россбанка, и не разбираясь со своими неисправным банкоматом сняли с меня опять такую же сумму (согласия на транзакцию никто им не давал, до этого говорили что так не могут, иначе я к этому банкомату вообще бы не пошел). Верните мне мои деньги ВОРЫ, если до вторника не вернут, придется обращаться в полицию, так как распоряжаться моими деньгами без моей воли, права не имеют. Хотя это делают.

Да, именно гаджеты, хотя это слово я не люблю.

Из последнего:
1) Ноутбук lenovo х120е — удивительный по юзабельности девайс, как только попробовал на нем поработать, понимаешь какими должны быть ноутбуки, очень удобная клавиатура, правильный софт в комплекте, и ощущение, что ты им всю жизнь пользовался, просто забыл, а потом нашел, тебе опять очень удобно… Пальцы попадают по нужным клавишам, экран матовый и не слепит. Все именно так как надо. Один мой друг како то взял его в руки, повертел, включил. Чего то понажимал, и сказал: «Я хочу такой же.» Он программист и большую часть жизни он проводит за компьютером. Может поэтому он почувствовал тоже, что и я.

2) Так же я поменял телефон вместо старого htc hero был преобретен google nexus s (9023). Тут примерно так же как и с lenovo, узнавание было сразу: «Я буду пользоваться этим девайсом, мне с ним удобно.» Теперь интересно, что скажет тот же друг программист.

Обе покупки не дорогие. И гаджеты не самые навернутые.
Но я стараюсь выбирать что нужно именно мне.

Долго выбирал ноутбук для себя.x120e

Из критерий показавшихся важными.

1) Матрица с разрешением минимум 1200×800 (минимально нормально для веб серфинга)

2) Время работы минимум 5 часов

3) Максимальный вес 2кг, размер 10-12 дюймов.

4) Удобная клавиатура (для небольших ноутбуков это важный параметр)

Собственно я не указал в критериях процессора, ОСь, и много другого. Так как лично мне оно не так критично, работать могу на линукс, виндовс, мак ось… Почти все выпускаемые ныне процессоры более чем шустры для повседневных дел, которые мне нужны от ноутбука.

Мытарства с хорошими и правильными кейсами, материками и другим обвесом для домашнего сервера закончил на том что выбрал полу за конченое решение от hp.
При прочих равных хороший самосбор обходиться в 17-20т.р. но как выяснилось есть готовое решение от hp, стоимостью в 12т.р. — это hp ProLiant MicroServer, которое обладает практически всеми преимуществами изначально.
Я решил добавить к конфигурации только дискретную графику от ATI например HD5450 дабы совместить хранилище и вывод на телевизор (дело в том, что в графике от ati интегрирован звуковой чип для вывода звука по HDMI).

Итак, hp ProLiant MicroServer под ubuntu и с дискретной графикой:

— 4 харда, в raid5 mdadm (пока поставил 3 харда 2ТБ… На большее денег не хватило),

— Asterisk как домашний сервер IP телефонии

— nginx и LAMP для всякой херни веб активности, типо фотки выложить, и т.д. ,

— плеер xpmb дабы фильмы выводить через HDMI,

— трансмишн демон для торентов

— днс сервер с dhcp

— Samba

Второй месяц я это всё использую, очень удобно. И главное очень тихо.